Coil.com Website
Incident Report for Coil
Resolved
This incident has been resolved.
Posted Jul 26, 2021 - 16:02 PDT
Investigating
We are currently experiencing issues with the Coil.com website.

We are working to resolve this as soon as possible. Thanks for your patience!
Posted Jul 26, 2021 - 16:02 PDT
This incident affected: Coil.com Website.