Coil Web Monetization
Incident Report for Coil
Resolved
This incident has been resolved.
Posted Feb 09, 2021 - 17:32 PST
Investigating
Coil Web Monetization for Coil Subscribers. Payments to creators are experiencing issues at this time.

We are working to resolve this as soon as possible. Thanks for your patience!
Posted Feb 09, 2021 - 14:08 PST
This incident affected: Coil Web Monetization.