Coil.com Website
Incident Report for Coil
Resolved
This incident has been resolved.
Posted Jun 18, 2020 - 10:31 PDT
Investigating
We are currently experiencing issues with the Coil.com website.

We are working to resolve this as soon as possible. Thanks for your patience!
Posted Jun 18, 2020 - 10:30 PDT
This incident affected: Coil.com Website.