Coil.com Website
Incident Report for Coil
Resolved
This incident has been resolved.
Posted Sep 25, 2020 - 23:22 PDT
Investigating
We are currently experiencing issues with the Coil.com website.

We are working to resolve this as soon as possible. Thanks for your patience!
Posted Sep 25, 2020 - 23:21 PDT
This incident affected: Coil.com Website.