Web Monetization Puma -> Uphold Payment Pointers
Incident Report for Coil
Resolved
This incident has been resolved.
Posted May 24, 2020 - 11:32 PDT
Investigating
Web Monetization payments using the Puma browser to Uphold Payment Pointers are currently having issues. We are actively working with Puma and Uphold to resolve these issues as soon as possible.

Thanks for your patience!
Posted May 22, 2020 - 15:28 PDT