Coil.com Website
Incident Report for Coil
Resolved
This incident has been resolved.
Posted Feb 18, 2021 - 19:37 PST
Investigating
We are currently experiencing issues with the Coil.com website.

We are working to resolve this as soon as possible. Thanks for your patience!
Posted Feb 18, 2021 - 19:27 PST
This incident affected: Coil.com Website.